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New Features & Enhancements in SC 11.1 G/

STRESSCHECK

a General GUI Cleanup, Tune-ups, Optimizations & Fixes
» Performance Improvements for Object Rendering and Loads Display/Updating

« Windows Layout Startup Preference Now Available in Options
o New Thin Section Automesh Method with Penta or Hexa-Dominant Option
o Boundary Layer Automesh Method Now with Mixed Mesh (Hexa/Penta/Tetra)
and Shrink-To-Fit/Trim-to-Fit Options
o Crack Front Automesh Method Now with Curvature D/H, Mixed Mesh,

Integration Layer, and Grade Toward Ends Options

« Also Extended to Cracks at Symmetry Planes
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New Global-Local Features for Load Scaling/Reversal

- Parametric TLAP Scaling for Linear and Incremental Nonlinear Analyses

New Features & Enhancements in SC 11.1 G/

STRESSCHECK

« Point Load and Point Constraint Object Displays Now Available in Case Definitions Dialogs

Improvements to COM API Functionality and Online Documentation

* Features Added for Multi-body Contact Analysis, TLAP CSV Importation and More

New Getting Started and Offline Documentation Available in Help Menu

- Easily Navigable and Searchable CHM Formats

Upgrades to Spatial Interop and MeshSim Libraries
« StressCheck v11.1 Now Supports InterOp2021.1.0.1 and MeshSim v17.0
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GENERAL GUI| CLEANUP, TUNE-UPS,

OPTIMIZATIONS & FIXES

Performance improvements for object rendering and loads display/updating
Windows layout startup preference now available in Options
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Optimized Grid/Pane/Dialog Behavior

STRESSCHECK

a The autohide of tabbed/pinned panes
and dialogs has been significantly
optimized, with no lag when
gaining/losing focus.

o Automesh progress dialog now appears
when changing parameters that force a
re-mesh.

o Enhanced/upgraded grid controls for
Parameters, Nonlinear Events, Point
Load/Constraint Definitions, Laminate
Stack, and other tabular input features.

o Improvements/fixes made to pane/dialog
persistence between StressCheck
sessions.
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Object Rendering Enhancements
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a Significant enhancements made to
HOOPs visualization features to

optimize the speed of element/model S
rendering. S —
. Reduced lag in drawing model updates. S T
- Users with larger models (e.g. >50k |
elements) will notice at least 2-5X faster ;
rotation/zoom/translation times when | : 1057130
interacting with the model display, evenat | =~
higher edge resolutions. o e Lo
o Additional cleanup of HOOPs
visualization features performed to :
enable larger model rendering and

future architectural modifications.
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Load Display/Updating Optimizations

STRESSCHECK
o Enhancements and re-factoring of the
display of load attributes (arrows) and Reset Display 195 95-100
the general updating of load case e [ E
records. Delete load record 15 2
 Significant improvements observed when giiz;:(el/oeonilt:eloodm ?g ZS &
displaying/updating loads for models with ez loelieoas | 146 57
large numbers of TLAP Traction/Bearing — 798
load records. Load Attributes ENABLED
- Adding/replacing/deleting load records [All values in seconds | StressCheck v11.0 | StressCheck vi1.1 ]
has been re-factored to reduce excessive Eg’e'fél'fp"ljym — A
CheCki ng ' Selectloadrecord 5-7 1
a The summary tables on right are from e 0
a model with 89k elements and Checkload D 95-105 65
dozens of TLAP load records, with D -
and without attributes enabled. Open SCW/Solvep=3 940 815

Load Attributes DISABLED
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Improved Column Ordering for Extractions

STRESSCHECK

o Data table columns for
Min/Max and Points
extractions have been
optimized for readability.

 Run # and extraction function
columns now precede
XYZ/RTZ columns.

 Local XYZ/RTZ columns now
precede global XYZ/RTZ
columns.

July 2022

Circular bar with flat in torsion
MinMax: Solution = SOL, runs #1 to #5
4 of 46 elements. 12 midsides (Face.Grid), Cart. System=1
Global Coord. (0.0, 0.0, 0.0), Rotations w.r.t. Global System (0.0, 0.0, 0.0)
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Estimated Max. = 3.702232e+01 at (6.725389¢-17.2.511466e-01,9.426179e-01). Run 5 error = 0.00%

Run DOF Max. Tmax Maximum Limit X (SYS1) Y (SYS1) Z (SYS1) X (Global) Y (Global) Z (Global)
1 1162 3.514963e+01 3.702232e+01 -1.282958e-02 2.505112e-01 9.384447e-01 -1.282958e-02 2.505112e-01 0.384447e-01
2 2118 3.676711e+01 3.702232e+01 -8.291562e-02 2.500000e-01 9.300000e-01 -8.291562e-02 2.500000e-01 9.300000e-01
3 3542 3.688862e+01 3.702232e+01 6.697075e-17 2.505104¢-01 9.384376e-01 6.697075¢-17 2.505104e-01 9.384376e-01
4 5572 3.701971e+01 3.702232e+01 6.725389%¢-17 2.511466e-01 9.426179e-01 6.725389%¢-17 2.511466e-01 9.426179¢-01
5 8346 3.702224e+01 3.702232e+01 6.725389¢-17 2.511466e-01 9.426179¢-01 6.725389¢-17 2.511466e-01 9.426179¢-01
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New Window Layout Startup Preference

STRESSCHECK
o A new preference is available under File > Options Options X
. Path to Scratch Directony:
for the WIndOW La'yOUt' C:A\Jzers\blancaster\dppDatatlLocalh)  Browse
« The default preference is to use the window layout Uits: in/bi/seciF
configuration from the user’s last session (Last Session). sraptes Ao ][ Check
. . Window Layout:  Last Seszion v
« This preference can be set to any saved window layout Line Thickness:  [1_|
available under View > Window Layout, or to use Object Resoltion: [100]
StressCheck v11.1’s default window layout (Default). Edge Resoltion: [20 |
Digplay Format: E
Courier New, 10 pt. | Display Font. ..
Lucida Console,9 pt. | Legend Font...
Show warning messages
Trace boundaries
Perspective
Image Export Dimensions
(®) Model Window
(O Custom 1048 ® 449
Default
1] % Cancel

July 2022 Copyright 2022 ESRD, Inc. All rights reserved. 9



July 2022

NEW THIN SECTION AUTOMESH METHOD

Incorporate pentas/nhexas through thin structures/regions (e.g. webs, skins)
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New Thin Section Automesh Method

o This new and powerful automeshing
feature creates a structured mesh of
several layers through a “thin” region.

« Specified by source and destination faces
(similar to the Extrude method).

« Supports mixed meshing (penta/hexaltetra)
via Pentahedron or Hexa-Dominant options.
o This feature is useful when meshing
areas that would otherwise produce
very high aspect ratio tetrahedrons that
may negatively impact solution quality
and computational time.
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ENHANCED BOUNDARY LAYER AUTOMESH
METHQOD

Include pentas/hexas and/or shrink to fit adjustments in boundary layer meshes
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Upgraded Boundary Layer Automesh Method @(

STRESSCHECK

o The existing Boundary Layer automesh
method has been enhanced to include
Mixed Mesh and Shrink to Fit options.

* Mixed Mesh (on by default) controls
whether the boundary layer mesh will be
constructed of only tetrahedrons (off) or a
mix of pentahedrons & hexahedrons (on).

= |f the boundary layer is applied to a surface, the
mesher will attempt to produce a quad-dominant
mesh on the selected surface in order to produce
a mostly hexahedral boundary layer mesh.

= |f applied, to a curve, the innermost layer of
elements will be all pentahedrons, with
hexahedrons in the outer layers.

« Shrink to Fit (off by default) controls
whether boundary layers will be trimmed or
shrunk to avoid intersections.
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ENHANCED CRACK FRONT AUTOMESH
METHOD

Include pentas/hexas, an integration layer of elements, and/or grade toward ends
refinement to crack front automeshes
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Upgraded Crack Front Automesh Method @(

STRESSCHECK

o The existing Crack Front automesh
method has been enhanced to include D/H
Curvature, Mixed Mesh, Integration Layer
and Grade Toward Ends options.
« Mixed Mesh (on by default) functions the
same as for the Boundary Layer method,
controlling whether the mesh around the

crack front is constructed entirely of tetras or
a mix of pentas and hexas.

* Integration Layer (on by default) will add an
additional layer of refinement around the
innermost layer for optimal fracture
extractions.

« Grade Toward Ends (off by default) will
produce a geometric gradation toward either
end of the selected curve.

o Crack Front method also extended to
support refinement at symmetry planes.
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NEwW GLOBAL-LOCAL FEATURES FOR LOAD
SCALING/REVERSAL

Parametric TLAP scaling for linear/incremental nonlinear analyses
Point Load and point constraint object displays now available in Case Definitions dialogs

July 2022 Copyright 2022 ESRD, Inc. All rights reserved.
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New Parametric TLAP Scaling Feature

STRESSCHECK
o Users will now have the option to apply
parametric scaling to TLAP loads. i Pararr
] ) L. calng Farameter: - .
- This functionality is implemented such that all ; LoadSealings
TLAPs under a single Case ID will be Display Optid LoadReverssl
uniformly scaled (i.e multiplied) by the current LoadS caling]
value of a scaling parameter. ] anatiw
* The scaling parameter may be any parameter [ Syrbols
defined within the model. [ Labels
* |tis selected using the Scaling Parameter
dropdown on the Point Load Case Definitions

dialog as shown on right.

o Parametric TLAP scaling is applicable to
linear, design study and incremental
nonlinear analyses.

« To be used in Nonlinear Events, it must be
defined as Class “B. Cond.”
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Extended Point Loads/Constraints Display Options

o TLAP and imported running load
display options are now available
directly from the Point Load Case
Definitions dialog (via Edit >
Point Load Info).

o Imported point
displacement/rotation display
options are now available directly
from the Point Constraint Case
Definitions dialog (via Edit >
Point Constraint Info).

July 2022

STRESSCHECK
Point Load Case Definitions b4
Curren t Case: + | CaselD: | MNumber: | . Scaling Parameter: ~
Location: ] | | i _ | Z | Display Options
Forces: % l ‘ Fy: _ ‘ Fz l [] Locations
Moment % ‘ ‘ My: l Mz l (] Symbols e
Thickness: | \ [Label
Add Replace lelete  ||Purge C Purge Al < Previous Mext >
Point Constraint Case Definitions x
Curent Case: « | CaszelD: . | Mumber: | ‘
Location: ®: ki _ | < | ‘ Display Options
Displacements: Ux; Uy: | Uz | ‘ [7] Locations
Rotations: B Ry . l Rz | ‘ [] Symbols (
[]Labels
Add Replace Delete | Purge Case | Purge All < Previous | Next»>
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ADDITIONAL ENHANCEMENTS AND FEATURES

New COM API Functionality and Documentation
New Getting Started and Offline Documentations

Copyright 2022 ESRD, Inc. All rights reserved.
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New COM API Functionality and Documentation

STRESSCHECK

o Key enhancements incorporated into
StressCheck’s COM API include:

« Multi-body contact solver options for iterations, max

v APl Overview

contact pressure error and ray tolerance 5 stressCheck COM API Overview
 Support for importation of TLAP CSV file formats 3 StressCheck Automation
« Element face set extractions/plots optimized for Fundamentals

performance =] Advanced StressCheck Automation:

- Surfaces collection now available for querying any Model Setup & Analysis
surface in the model [E Advanced StressCheck

o New online documentation articles available for ﬂ:ﬁ.ﬁ.’;}ﬂ:m: Model Editing &
users learning StressCheck's COM API.

o https://www.esrd.com/support/stresscheck-
documentation/stresscheck-com-api-overview/

« Code snippets in VBA and Python

=] Commonly Used StressCheck API
Functions
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New Offline Documentations Available Under Help G/

o The Help menu has been revamped to

Include new Getting Started and Offline

Documentation options.

The Getting Started guide has been
upgraded from a simple PDF to an easily
navigable/searchable CHM file.

The Offline Documentation has been
converted from a continuous PDF to an
expansive, comprehensive CHM file

organized by topic/keyword and incorporating

playable GIFs of StressCheck’s features.

a2 An Online Documentation option is still
available for the latest documentation
updates.

July 2022

https://www.esrd.com/support/stresscheck-

Help
Getting Started E
Online Documentation
Offline Documentation

COM Programming Help

Copyright Notice

About StressCheck...

STRESSCHECK

documentation/

[ StressCheck v11.1 Offline Documentation - m] X
& Al i
Hide Locate Back Home  Prnt  Opiions
Contens | ipdex | Search | Favortes| GUI Standards & Layout Overview A
Introduction ‘GUI Standards & Layout »
= (@ GUI Standards & Layout
SERSUCERIENIN | GUI Standards & Layout Overview
& Gl Basics Introduction
@ Main M
@ Toolbars StressChecke is based on Microsoft Windows graphic user interface development tools, therefore following standard MFC conventions for interacting with the program. In the
@ Object Management & Visy| || following, the StressChecke user interface layout, dialogs and interface conventions are discussed.

B W@ Model Inputs
Model Inputs Overview
[ Importing Model Inputs As shown in Figure 1, the user interface consists of a Main M

Interface Layout

ht of th :
@ Materials & Other Properti right ofthe screen

@ Boundary Conditions
@ Discretization Features

interface consists of a lenu Bar lectors (Main Too
@ CAD Geomet ry the top of the screen, a graphic Model View (with a persisting tab indicating the name of the current project

proj
@ Manual & Automatic Meshi || below the Model View, four Toolbars (Views, Edit, Display Options, and Display Objects) at the bottom of the screen, and a Simulation pane containing tabbed dialogs at the

Ibar/Menu, Display Attributes, Reference/Theory/Units, and Parts) at
) in the center of the screen, logging and model information panes
imi ane Col

= W Solvers
[2 Solvers Overview
@ Solver Basics & Linear Anal
@ Nonlinear Solvers
@ Other Solvers
= (@ Results
Results Overview
® Results Basics
Plot Solution Overview
@ Extracting Tabular Data
@ Advanced Features & Analysig
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https://www.esrd.com/support/stresscheck-documentation/

QUESTIONS OR COMMENTS?

Contact support@esrd.com
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